Project

General

Profile

Improvement #2006

Upgrade and remove libraries

Added by Henning Blohm over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
z2-base
Target version:
Start date:
10.05.2018
Due date:
% Done:

0%

Estimated time:
origin:

Description

Some stuff we need to get in shape:

  • apache commons libs used in z2 need to be updated and should be discouraged to be used by applications that should rather bring their own.
  • codehaus jackson is ancient and should be removed from public z2unit exposure
  • log4j, slf4j to be updated.

Related issues

Is duplicate of z2-Environment - Improvement #1983: Hide external libraries used in z2 base impl.Resolved26.09.2017Henning Blohm

Actions
#1

Updated by Henning Blohm over 4 years ago

  • Status changed from In Progress to To Be Documented
#2

Updated by Henning Blohm over 4 years ago

  • Status changed from To Be Documented to Resolved
#3

Updated by Henning Blohm over 4 years ago

  • Is duplicate of Improvement #1983: Hide external libraries used in z2 base impl. added

Also available in: Atom PDF