Project

General

Profile

Bug #2096

In rare cases an API jar is missing

Added by Henning Blohm 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
z2-core
Target version:
Start date:
29.06.2021
Due date:
% Done:

0%

Estimated time:
origin:

Description

E.g.

Caused by: java.lang.IllegalStateException: Classpath construction - Failed to introspect file:/home/hb/workspace_zf-work/zf-work.core/z2-base.core/bin/../work/repos/com_zfabrik_dev_repo_devRepo/pkg/com_zfabrik_work_portal/java/17a599e7d06_00/bin.api/lib/com.zfabrik.work.portal.api.jar
     at com.zfabrik.impl.components.java.ComponentClassLoader$ClassPath.init(ComponentClassLoader.java:436)
     at com.zfabrik.impl.components.java.ComponentClassLoader$ClassPath.locate(ComponentClassLoader.java:493)
     at com.zfabrik.impl.components.java.ComponentClassLoader.findResource(ComponentClassLoader.java:838)
     at com.zfabrik.impl.components.java.ComponentClassLoader.getResource(ComponentClassLoader.java:825)
     at java.base/java.net.URLClassLoader.getResourceAsStream(URLClassLoader.java:322)
     at com.zfabrik.impl.components.java.jdt.NameEnvironmentImpl._findType(NameEnvironmentImpl.java:172)
     at com.zfabrik.impl.components.java.jdt.NameEnvironmentImpl.findType(NameEnvironmentImpl.java:52)
     at org.eclipse.jdt.internal.compiler.lookup.LookupEnvironment.createPlainPackage(LookupEnvironment.java:1139)
     at org.eclipse.jdt.internal.compiler.lookup.CompilationUnitScope.buildTypeBindings(CompilationUnitScope.java:135)
     at org.eclipse.jdt.internal.compiler.lookup.LookupEnvironment.buildTypeBindings(LookupEnvironment.java:475)
     at org.eclipse.jdt.internal.compiler.Compiler.internalBeginToCompile(Compiler.java:855)
     at org.eclipse.jdt.internal.compiler.Compiler.beginToCompile(Compiler.java:394)
     at org.eclipse.jdt.internal.compiler.Compiler.compile(Compiler.java:444)
     at org.eclipse.jdt.internal.compiler.Compiler.compile(Compiler.java:426)
     at com.zfabrik.impl.components.java.jdt.SimpleJDTCompiler.compile(SimpleJDTCompiler.java:128)
     at com.zfabrik.impl.components.java.jdt.JavaCompilerComponent.compile(JavaCompilerComponent.java:24)
     at com.zfabrik.components.java.build.ICompiler.compile(ICompiler.java:121)
     ... 45 more
 Caused by: java.nio.file.NoSuchFileException: /home/hb/workspace_zf-work/zf-work.core/z2-base.core/bin/../work/repos/com_zfabrik_dev_repo_devRepo/pkg/com_zfabrik_work_portal/java/17a599e7d06_00/bin.api/lib/com.zfabrik.work.portal.api.jar
     at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:92)
     at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)
     at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:116)

but the folder work/repos/com_zfabrik_dev_repo_devRepo/pkg/com_zfabrik_work_portal/java/17a599e7d06_00/bin.api/lib/ does actually exist.

As if the API jar was there but then removed again, or as if API compilation actually failed but the failure was not noticed.

#1

Updated by Henning Blohm 4 months ago

  • Description updated (diff)
#2

Updated by Henning Blohm 4 months ago

This first problem is this:

 06/29 23:16:42 [19]...ComponentsBuilder [1000]: Component Build failed with error: com.zfabrik.work.portal/java
 java.lang.reflect.UndeclaredThrowableException
     at com.sun.proxy.$Proxy5.compile(Unknown Source)
     at com.zfabrik.impl.compiler.CompilerFactory$C.compile(CompilerFactory.java:63)
     at com.zfabrik.impl.compiler.AllCompiler.compile(AllCompiler.java:73)
     at com.zfabrik.impl.components.java.BuildHelper.compileAndJar(BuildHelper.java:140)
     at com.zfabrik.impl.components.java.ComponentsBuilder._makePart(ComponentsBuilder.java:620)
     at com.zfabrik.impl.components.java.ComponentsBuilder.make(ComponentsBuilder.java:297)
     at com.zfabrik.impl.components.java.JavaComponentImpl.lambda$as$0(JavaComponentImpl.java:154)
     at java.base/java.security.AccessController.doPrivileged(Native Method)
     at com.zfabrik.impl.components.java.JavaComponentImpl.as(JavaComponentImpl.java:93)
     at com.zfabrik.impl.components.ComponentResourceWrapper.as(ComponentResourceWrapper.java:86)
     at com.zfabrik.resources.provider.Resource.as(Resource.java:149)
     at com.zfabrik.impl.resources.ResourceHandleImpl.lambda$as$0(ResourceHandleImpl.java:85)
     at com.zfabrik.work.CycleProtector.supply(CycleProtector.java:117)
     at com.zfabrik.impl.resources.ResourceHandleImpl.as(ResourceHandleImpl.java:62)
     at com.zfabrik.impl.resources.ResourceHandleImpl.as(ResourceHandleImpl.java:96)
     at com.zfabrik.components.java.JavaComponentUtil.getPrivateLoaderOfJavaComponent(JavaComponentUtil.java:166)
     at com.zfabrik.components.java.JavaComponentUtil.getPrivateLoaderOfJavaComponent(JavaComponentUtil.java:178)
     at com.zfabrik.components.java.JavaComponentUtil.privateContextExceptionExecute(JavaComponentUtil.java:242)
     at com.zfabrik.impl.components.ComponentDependencyUtil.prepareDependencies(ComponentDependencyUtil.java:69)
     at com.zfabrik.impl.components.states.SystemStateResource._prepareDependencies(SystemStateResource.java:85)
     at com.zfabrik.impl.components.states.SystemStateResource.prepare(SystemStateResource.java:66)
     at com.zfabrik.impl.workers.worker.WorkerSoul.loadDependencies(WorkerSoul.java:338)
     at com.zfabrik.impl.workers.worker.WorkerSoul.loadDependencies(WorkerSoul.java:323)
     at com.zfabrik.impl.workers.worker.WorkerSoul.processMessage(WorkerSoul.java:402)
     at com.zfabrik.impl.workers.MessageExchange$MessageHandling.run(MessageExchange.java:123)
     at com.zfabrik.work.WorkUnit.lambda$work$0(WorkUnit.java:356)
     at com.zfabrik.work.WorkUnit.supply(WorkUnit.java:368)
     at com.zfabrik.work.WorkUnit.work(WorkUnit.java:356)
     at com.zfabrik.impl.work.ThreadPoolImpl.doIt(ThreadPoolImpl.java:295)
     at com.zfabrik.impl.work.ThreadPoolImpl.lambda$wrap$1(ThreadPoolImpl.java:185)
     at com.zfabrik.work.WorkUnit.lambda$work$0(WorkUnit.java:356)
     at com.zfabrik.work.WorkUnit.supply(WorkUnit.java:368)
     at com.zfabrik.work.WorkUnit.work(WorkUnit.java:356)
     at com.zfabrik.impl.work.ThreadPoolImpl.doIt(ThreadPoolImpl.java:295)
     at com.zfabrik.impl.work.WorkerThread.run(WorkerThread.java:60)
 Caused by: java.lang.reflect.InvocationTargetException
     at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
     at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     at java.base/java.lang.reflect.Method.invoke(Method.java:566)
     at com.zfabrik.components.java.JavaComponentUtil$1$1.call(JavaComponentUtil.java:230)
     at com.zfabrik.util.threading.ThreadUtil.lambda$cleanContextExceptionExecute$0(ThreadUtil.java:55)
     at java.base/java.security.AccessController.doPrivileged(Native Method)
     at com.zfabrik.util.threading.ThreadUtil.cleanContextExceptionExecute(ThreadUtil.java:55)
     at com.zfabrik.util.threading.ThreadUtil.cleanContextExceptionExecute(ThreadUtil.java:76)
     at com.zfabrik.components.java.JavaComponentUtil$1.invoke(JavaComponentUtil.java:227)
     ... 35 more
 Caused by: java.lang.IllegalStateException: Classpath construction - Failed to introspect file:/home/hb/workspace_zf-work/zf-work.core/z2-base.core/bin/../work/repos/com_zfabrik_dev_repo_devRepo/pkg/com_zfabrik_work_portal/java/17a599e7d06_00/bin.api/lib/com.zfabrik.work.portal.api.jar
     at com.zfabrik.impl.components.java.ComponentClassLoader$ClassPath.init(ComponentClassLoader.java:436)
     at com.zfabrik.impl.components.java.ComponentClassLoader$ClassPath.locate(ComponentClassLoader.java:493)
     at com.zfabrik.impl.components.java.ComponentClassLoader.findResource(ComponentClassLoader.java:838)
     at com.zfabrik.impl.components.java.ComponentClassLoader.getResource(ComponentClassLoader.java:825)
     at java.base/java.net.URLClassLoader.getResourceAsStream(URLClassLoader.java:322)
     at com.zfabrik.impl.components.java.jdt.NameEnvironmentImpl._findType(NameEnvironmentImpl.java:172)
     at com.zfabrik.impl.components.java.jdt.NameEnvironmentImpl.findType(NameEnvironmentImpl.java:52)
     at org.eclipse.jdt.internal.compiler.lookup.LookupEnvironment.createPlainPackage(LookupEnvironment.java:1139)
     at org.eclipse.jdt.internal.compiler.lookup.CompilationUnitScope.buildTypeBindings(CompilationUnitScope.java:135)
     at org.eclipse.jdt.internal.compiler.lookup.LookupEnvironment.buildTypeBindings(LookupEnvironment.java:475)
     at org.eclipse.jdt.internal.compiler.Compiler.internalBeginToCompile(Compiler.java:855)
     at org.eclipse.jdt.internal.compiler.Compiler.beginToCompile(Compiler.java:394)
     at org.eclipse.jdt.internal.compiler.Compiler.compile(Compiler.java:444)
     at org.eclipse.jdt.internal.compiler.Compiler.compile(Compiler.java:426)
     at com.zfabrik.impl.components.java.jdt.SimpleJDTCompiler.compile(SimpleJDTCompiler.java:128)
     at com.zfabrik.impl.components.java.jdt.JavaCompilerComponent.compile(JavaCompilerComponent.java:24)
     at com.zfabrik.components.java.build.ICompiler.compile(ICompiler.java:121)
     ... 45 more
 Caused by: java.nio.file.NoSuchFileException: /home/hb/workspace_zf-work/zf-work.core/z2-base.core/bin/../work/repos/com_zfabrik_dev_repo_devRepo/pkg/com_zfabrik_work_portal/java/17a599e7d06_00/bin.api/lib/com.zfabrik.work.portal.api.jar
     at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:92)
     at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)
     at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:116)
     at java.base/sun.nio.fs.UnixFileAttributeViews$Basic.readAttributes(UnixFileAttributeViews.java:55)
     at java.base/sun.nio.fs.UnixFileSystemProvider.readAttributes(UnixFileSystemProvider.java:145)
     at java.base/sun.nio.fs.LinuxFileSystemProvider.readAttributes(LinuxFileSystemProvider.java:99)
     at java.base/java.nio.file.Files.readAttributes(Files.java:1763)
     at java.base/java.util.zip.ZipFile$Source.get(ZipFile.java:1222)
     at java.base/java.util.zip.ZipFile$CleanableResource.<init>(ZipFile.java:726)
     at java.base/java.util.zip.ZipFile$CleanableResource.get(ZipFile.java:843)
     at java.base/java.util.zip.ZipFile.<init>(ZipFile.java:246)
     at java.base/java.util.zip.ZipFile.<init>(ZipFile.java:176)
     at java.base/java.util.jar.JarFile.<init>(JarFile.java:346)
     at java.base/java.util.jar.JarFile.<init>(JarFile.java:317)
     at com.zfabrik.impl.components.java.ComponentClassLoader$ClassPath.init(ComponentClassLoader.java:414)
     ... 61 more
#3

Updated by Henning Blohm 4 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF