Project

General

Profile

Feature #2109

Evaluate Java 8 supporting port of v2.9

Added by Henning Blohm about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
23.09.2021
Due date:
% Done:

0%

Estimated time:
origin:

Description

As there are still some larger environments relying on Java 8 for the foreseeable future, we should evaluate the possibility
to create a easy to maintain Java 8 port of v2.9 as v2.9b.

  • In particular this means to support Jetty 9.4.x and Servlet API 3.1 (see https://www.eclipse.org/jetty/)
  • Within that Jetty support we need to support web-fragments from the classpath

Implementation Hints

  • On fragment support

The problem with Jetty < 10 is that in MetaData.resolve Jetty only considers Fragments that have been found in "WebInfJars". That is, although the scanning actually discovers fragments on the classpath, Jetty does not include them.

On the other hand, if we force other Jars as WebInfJars, Jetty will discover resources twice and quite noisily complain about that in AnnotationParser.addParsedClass.

#1

Updated by Henning Blohm about 1 year ago

  • Target version changed from TBD to 2.9b
#2

Updated by Henning Blohm about 1 year ago

  • Description updated (diff)
#3

Updated by Henning Blohm about 1 year ago

  • Status changed from In Progress to Feedback
#4

Updated by Henning Blohm about 1 year ago

  • Description updated (diff)
#5

Updated by Henning Blohm about 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF