Project

General

Profile

Bug #896

Problem when starting z2 core for SVN system repository

Added by Henning Blohm about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
z2-core
Target version:
Start date:
12.09.2012
Due date:
% Done:

100%

Estimated time:
origin:

Description

Reproducibly gives

java.lang.ExceptionInInitializerError
at com.zfabrik.impl.svncr.ComponentRepositoryImpl.getRepoSession(ComponentRepositoryImpl.java:586)
at com.zfabrik.impl.svncr.ComponentRepositoryImpl.scan(ComponentRepositoryImpl.java:199)
at com.zfabrik.impl.svncr.ComponentRepositoryImpl.scan(ComponentRepositoryImpl.java:94)
at com.zfabrik.components.provider.util.AbstractComponentRepository.checkDB(AbstractComponentRepository.java:511)
at com.zfabrik.components.provider.util.AbstractComponentRepository.start(AbstractComponentRepository.java:190)
at com.zfabrik.impl.svncr.ComponentRepositoryResource._load(ComponentRepositoryResource.java:68)
at com.zfabrik.impl.svncr.ComponentRepositoryResource.prepare(ComponentRepositoryResource.java:62)
at com.zfabrik.impl.components.states.SystemStateResource.attain(SystemStateResource.java:139)
at com.zfabrik.impl.components.states.SystemStateResource.attempting(SystemStateResource.java:79)
at com.zfabrik.impl.components.states.SystemStateResource.attain(SystemStateResource.java:126)
at com.zfabrik.impl.components.states.SystemStateResource.attempting(SystemStateResource.java:79)
at com.zfabrik.impl.components.states.SystemStateResource.attain(SystemStateResource.java:126)
at com.zfabrik.impl.components.states.SystemStateResource$1.run(SystemStateResource.java:46)
at com.zfabrik.impl.launch.ProcessRunnerImpl.start(ProcessRunnerImpl.java:177)
at launchers.HomeLauncher.run(HomeLauncher.java:175)
at launchers.HomeLauncher.main(HomeLauncher.java:106)
Caused by: java.lang.IllegalStateException: subversion accessor com.zfabrik.boot.svnaccess/svnAccessor not available
at com.zfabrik.svnaccess.ISVNAccessor$Initializer.get(ISVNAccessor.java:50)
at com.zfabrik.svnaccess.ISVNAccessor$Initializer.access$000(ISVNAccessor.java:38)
at com.zfabrik.svnaccess.ISVNAccessor.<clinit>(ISVNAccessor.java:59)
... 16 more
Caused by: java.nio.channels.OverlappingFileLockException
at sun.nio.ch.FileChannelImpl$SharedFileLockTable.checkList(FileChannelImpl.java:1166)
at sun.nio.ch.FileChannelImpl$SharedFileLockTable.add(FileChannelImpl.java:1068)
at sun.nio.ch.FileChannelImpl.lock(FileChannelImpl.java:824)
at java.nio.channels.FileChannel.lock(FileChannel.java:860)
at com.zfabrik.components.provider.util.LockingRevFile.open(LockingRevFile.java:67)
at com.zfabrik.components.provider.util.FSComponentRepositoryHelper.lockDB(FSComponentRepositoryHelper.java:114)
at com.zfabrik.components.provider.util.AbstractComponentRepository.checkDB(AbstractComponentRepository.java:493)
at com.zfabrik.components.provider.util.AbstractComponentRepository.findComponents(AbstractComponentRepository.java:316)
at com.zfabrik.components.provider.util.AbstractComponentRepository.findComponents(AbstractComponentRepository.java:309)
at com.zfabrik.impl.components.local.FSRepository.findComponents(FSRepository.java:70)
at com.zfabrik.impl.components.local.FSRepository.findComponents(FSRepository.java:61)
at com.zfabrik.impl.components.ComponentsManager.findComponents(ComponentsManager.java:146)
at com.zfabrik.impl.components.ComponentsManager.findComponents(ComponentsManager.java:135)
at com.zfabrik.impl.components.ComponentResourceWrapper._load(ComponentResourceWrapper.java:246)
at com.zfabrik.impl.components.ComponentResourceWrapper._check(ComponentResourceWrapper.java:105)
at com.zfabrik.impl.components.ComponentResourceWrapper.as(ComponentResourceWrapper.java:69)
at com.zfabrik.impl.resources.ResourceHandleImpl.as(ResourceHandleImpl.java:70)
at com.zfabrik.impl.resources.NamespaceImpl.lookup(NamespaceImpl.java:182)
at com.zfabrik.components.IComponentsLookup$initializer$1.lookup(IComponentsLookup.java:61)
at com.zfabrik.svnaccess.ISVNAccessor$Initializer.get(ISVNAccessor.java:47)
... 18 more

#1

Updated by Henning Blohm about 8 years ago

  • Status changed from New to In Progress
#2

Updated by Henning Blohm about 8 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100
#3

Updated by Henning Blohm about 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF