Project

General

Profile

Bug #898

SVNCR treats files as directory nodes

Added by Udo Offermann about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
z2-core
Target version:
Start date:
13.09.2012
Due date:
% Done:

0%

Estimated time:
origin:

Description

SVNCR failes when the first level contains files:

09/13 11:38:38 [1]...entRepositoryImpl[ 800]: Using SVN Repository com.zfabrik.impl.svncr.ComponentRepositoryImpl@395fd251,repo:246d0e3e, component:com.zfabrik.boot.config/systemRepository, prio:500, url:svn://z2-environment.net/z2-master/trunk/z2-base.base, username:z2-master
09/13 11:38:41 [1]...stemStateResource[ 1000]: Error when trying to call prepare(...) on "com.zfabrik.boot.config/systemRepository"
java.lang.RuntimeException: Scan on SVN repo failed: com.zfabrik.boot.config/systemRepository
at com.zfabrik.impl.svncr.ComponentRepositoryImpl.scan(ComponentRepositoryImpl.java:225)
at com.zfabrik.impl.svncr.ComponentRepositoryImpl.scan(ComponentRepositoryImpl.java:94)
at com.zfabrik.components.provider.util.AbstractComponentRepository.checkDB(AbstractComponentRepository.java:516)
at com.zfabrik.components.provider.util.AbstractComponentRepository.start(AbstractComponentRepository.java:191)
at com.zfabrik.impl.svncr.ComponentRepositoryResource._load(ComponentRepositoryResource.java:68)
at com.zfabrik.impl.svncr.ComponentRepositoryResource.prepare(ComponentRepositoryResource.java:62)
at com.zfabrik.impl.components.states.SystemStateResource.attain(SystemStateResource.java:139)
at com.zfabrik.impl.components.states.SystemStateResource.attempting(SystemStateResource.java:79)
at com.zfabrik.impl.components.states.SystemStateResource.attain(SystemStateResource.java:126)
at com.zfabrik.impl.components.states.SystemStateResource.attempting(SystemStateResource.java:79)
at com.zfabrik.impl.components.states.SystemStateResource.attain(SystemStateResource.java:126)
at com.zfabrik.impl.components.states.SystemStateResource$1.run(SystemStateResource.java:46)
at com.zfabrik.impl.launch.ProcessRunnerImpl.start(ProcessRunnerImpl.java:177)
at launchers.HomeLauncher.run(HomeLauncher.java:175)
at launchers.HomeLauncher.main(HomeLauncher.java:106)
Caused by: org.tmatesoft.svn.core.SVNException: svn: Can't get entries of non-directory
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
at org.tmatesoft.svn.core.internal.io.svn.SVNReader.handleFailureStatus(SVNReader.java:263)
at org.tmatesoft.svn.core.internal.io.svn.SVNReader.parse(SVNReader.java:242)
at org.tmatesoft.svn.core.internal.io.svn.SVNConnection.read(SVNConnection.java:260)
at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.read(SVNRepositoryImpl.java:1275)
at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.getDir(SVNRepositoryImpl.java:453)
at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.getDir(SVNRepositoryImpl.java:413)
at com.zfabrik.impl.svncr.ComponentRepositoryImpl.readModuleComponents(ComponentRepositoryImpl.java:444)
at com.zfabrik.impl.svncr.ComponentRepositoryImpl.fullScan(ComponentRepositoryImpl.java:396)
at com.zfabrik.impl.svncr.ComponentRepositoryImpl.scan(ComponentRepositoryImpl.java:206)
... 14 more

#1

Updated by Udo Offermann about 8 years ago

  • Description updated (diff)
#2

Updated by Udo Offermann about 8 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF