Bug #1877

Eclipsoid preventing running Main program from Eclipse in Z2-Module

Added by Henning Blohm almost 3 years ago. Updated over 2 years ago.

Status:ResolvedStart date:28.01.2015
Priority:NormalDue date:
Assignee:Udo Offermann% Done:

100%

Category:z2-base-tools-eclipsoid
Target version:3.0
origin:

Description

When running a Main program from a Z2-Module in Eclipse, i.e. the .classpath file contains the Eclipsoid container, I get

java.lang.RuntimeException: No Project References available
    at com.zfabrik.eclipsoid.client.StartEclipsoid.getClassPathEntries(StartEclipsoid.java:281)
    at com.zfabrik.eclipsoid.plugin.cpcontainer.EclipsoidClasspathEntryResolver.resolveRuntimeClasspathEntry(EclipsoidClasspathEntryResolver.java:89)
    at com.zfabrik.eclipsoid.plugin.cpcontainer.EclipsoidClasspathEntryResolver.resolveRuntimeClasspathEntry(EclipsoidClasspathEntryResolver.java:63)
    at org.eclipse.jdt.internal.launching.RuntimeClasspathEntryResolver.resolveRuntimeClasspathEntry(RuntimeClasspathEntryResolver.java:45)
    at org.eclipse.jdt.launching.JavaRuntime.resolveRuntimeClasspathEntry(JavaRuntime.java:942)
    at org.eclipse.jdt.internal.launching.DefaultEntryResolver.resolveRuntimeClasspathEntry(DefaultEntryResolver.java:38)
    at org.eclipse.jdt.launching.JavaRuntime.resolveRuntimeClasspathEntry(JavaRuntime.java:958)
    at org.eclipse.jdt.launching.StandardClasspathProvider.resolveClasspath(StandardClasspathProvider.java:75)
    at org.eclipse.jdt.launching.JavaRuntime.resolveRuntimeClasspath(JavaRuntime.java:1258)
    at org.eclipse.jdt.launching.AbstractJavaLaunchConfigurationDelegate.getClasspath(AbstractJavaLaunchConfigurationDelegate.java:412)
    at org.eclipse.jdt.launching.JavaLaunchDelegate.launch(JavaLaunchDelegate.java:71)
    at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:885)
    at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:739)
    at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1039)
    at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1256)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: java.io.FileNotFoundException: /home/hb/org.z2env/.eclipsoid/eclipsoid.properties (No such file or directory)
    at java.io.FileInputStream.open(Native Method)
    at java.io.FileInputStream.<init>(FileInputStream.java:138)
    at com.zfabrik.eclipsoid.client.StartEclipsoid.getClassPathEntries(StartEclipsoid.java:278)
    ... 15 more

i.e. the missing file is assumed to exist, even though there never was a successful sync.

Associated revisions

Revision 406db4db
Added by Udo Offermann over 2 years ago

refs #1877 @1h - Eclipsoid preventing running Main program from Eclipse
in Z2-Module
  • add check if propsFile exists

History

#2 Updated by Udo Offermann over 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF