Project

General

Profile

Feature #1950

Z2Unit-TestExecutor should support Junit suites and Parameterized tests

Added by Udo Offermann over 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
z2-base
Target version:
Start date:
20.06.2016
Due date:
% Done:

0%

Estimated time:
origin:

Description

Z2Unit should support Parameterized-tests and Aggregating-tests-in-suites

One thing to look at is the filter in TestExecutor.java

  r = r.filterWith(new Filter() {
    @Override
    public boolean shouldRun(Description d) {
        return description.equals(d) || children.containsKey(d);
    }
  ...                    

Furthermore the JSONHelper must be extended - see attached patch

NOTE: Parameterized tests have been fixed with #1971. Aggregation testing needs to be verified and test coverage supplied


Files

patched_JSON_Helper.patch (3.67 KB) patched_JSON_Helper.patch Udo Offermann, 21.06.2016 08:51

Related issues

Is duplicate of z2-Environment - Bug #1971: z2unit TestExecutor filtering out all tests when used with Parameterized runnerResolved12.04.2017Henning Blohm

Actions
#1

Updated by Udo Offermann over 4 years ago

#2

Updated by Udo Offermann over 4 years ago

  • Description updated (diff)
#3

Updated by Henning Blohm over 4 years ago

  • Target version set to 2.5
#4

Updated by Henning Blohm over 3 years ago

  • Target version changed from 2.5 to 2.6
#5

Updated by Henning Blohm about 3 years ago

  • Is duplicate of Bug #1971: z2unit TestExecutor filtering out all tests when used with Parameterized runner added
#6

Updated by Henning Blohm about 3 years ago

  • Description updated (diff)
#7

Updated by Henning Blohm almost 3 years ago

  • Status changed from New to Resolved

as dup

Also available in: Atom PDF