Project

General

Profile

Bug #902

CheckoutException during initial z2 triggered cloning when file has windows line endings

Added by Henning Blohm about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
z2-core
Target version:
Start date:
14.09.2012
Due date:
% Done:

0%

Estimated time:
origin:

Description

09/14 10:08:02 [1]...stemStateResource1000: Error when trying to call prepare(...) on "com.zfabrik.boot.config/systemRepository"
com.zfabrik.impl.gitcr.GitComponentRepositoryImpl$CloneFailedException: Failed to clone GitCR com.zfabrik.boot.config/systemRepository (origin=http://
git.z2-environment.net/z2-base.base, branch=master) com.zfabrik.impl.gitcr.GitComponentRepositoryImpl@33c658,repo:246d0e3e, component:com.zfabrik.boot
.config/systemRepository, prio:500, checkDepth:1073741823, fileSystem:com.zfabrik.components.provider.fs.FileSystemImpl@122c9df, root:C:\Users\hb\inst
all\z2-base.core\run\bin\..\..\work\repos\246d0e3e\git to C:\Users\hb\install\z2-base.core\run\bin\..\..\work\repos\246d0e3e\git
at com.zfabrik.impl.gitcr.GitComponentRepositoryImpl.cloneRepository(GitComponentRepositoryImpl.java:208)
at com.zfabrik.impl.gitcr.GitComponentRepositoryImpl.doClone(GitComponentRepositoryImpl.java:160)
at com.zfabrik.impl.gitcr.GitComponentRepositoryImpl.scan(GitComponentRepositoryImpl.java:145)
at com.zfabrik.components.provider.util.AbstractComponentRepository.checkDB(AbstractComponentRepository.java:511)
at com.zfabrik.components.provider.util.AbstractComponentRepository.start(AbstractComponentRepository.java:190)
at com.zfabrik.impl.gitcr.GitComponentRepositoryResource._load(GitComponentRepositoryResource.java:61)
at com.zfabrik.impl.gitcr.GitComponentRepositoryResource.prepare(GitComponentRepositoryResource.java:55)
at com.zfabrik.impl.components.states.SystemStateResource.attain(SystemStateResource.java:139)
at com.zfabrik.impl.components.states.SystemStateResource.attempting(SystemStateResource.java:79)
at com.zfabrik.impl.components.states.SystemStateResource.attain(SystemStateResource.java:126)
at com.zfabrik.impl.components.states.SystemStateResource.attempting(SystemStateResource.java:79)
at com.zfabrik.impl.components.states.SystemStateResource.attain(SystemStateResource.java:126)
at com.zfabrik.impl.components.states.SystemStateResource$1.run(SystemStateResource.java:46)
at com.zfabrik.impl.launch.ProcessRunnerImpl.start(ProcessRunnerImpl.java:177)
at launchers.HomeLauncher.run(HomeLauncher.java:175)
at launchers.HomeLauncher.main(HomeLauncher.java:106)
Caused by: org.eclipse.jgit.api.errors.CheckoutConflictException: Checkout conflict with files:
environment/logging/logging.properties
at org.eclipse.jgit.api.CheckoutCommand.call(CheckoutCommand.java:177)
at com.zfabrik.impl.helper.GitTools.switchBranch(GitTools.java:32)
at com.zfabrik.impl.gitcr.GitComponentRepositoryImpl.cloneRepository(GitComponentRepositoryImpl.java:192)
... 15 more
Caused by: org.eclipse.jgit.errors.CheckoutConflictException: Checkout conflict with files:
environment/logging/logging.properties
at org.eclipse.jgit.dircache.DirCacheCheckout.doCheckout(DirCacheCheckout.java:405)
at org.eclipse.jgit.dircache.DirCacheCheckout.checkout(DirCacheCheckout.java:385)
at org.eclipse.jgit.api.CheckoutCommand.call(CheckoutCommand.java:173)
... 17 more

#1

Updated by Henning Blohm about 8 years ago

Happens when core.autocrlf = input but not when core.autocrlf=true or core.autocrlf=false

#2

Updated by Udo Offermann about 8 years ago

  • Status changed from New to Rejected
#3

Updated by Henning Blohm about 8 years ago

  • Status changed from Rejected to New

Observed again. Re-opening.

Suggestion: Mimick

mkdir $BRANCH
cd $BRANCH
git init
git remote add -t $BRANCH -f origin $REMOTE_REPO
git checkout $BRANCH

as in http://stackoverflow.com/questions/1911109/git-clone-a-specific-branch and set config after init.

#4

Updated by Udo Offermann about 8 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF