Project

General

Profile

Bug #922

Eclipsoid component is not started when some other web app fails

Added by Udo Offermann about 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
z2-core
Target version:
Start date:
28.09.2012
Due date:
% Done:

100%

Estimated time:
origin:

Description

Steps to reproduce:

Create new z2 web project using the Eclipsoid wizard and arm it.
It will create a new project with an "invalid" webapp.path property inside web/z.properties
Leave the invalid webapp.path value and start the server. Starting the new web app will fail because of the invalid context name.
However Eclipsoid isn't started as well!

#1

Updated by Udo Offermann about 9 years ago

  • Priority changed from High to Urgent
#2

Updated by Henning Blohm almost 9 years ago

More specifically:

When adding a component as dependency to a worker target state and that component fails, any other participation to that state will not be followed.

Root cause is that the core-level dependency preparation already fails and so the prepare step of the state component itself will not be run.

#3

Updated by Henning Blohm almost 9 years ago

  • Status changed from New to In Progress
#4

Updated by Henning Blohm almost 9 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100
#5

Updated by Henning Blohm almost 9 years ago

  • Status changed from Resolved to In Progress
re-opening. dependency handling is not clean when done generically on component level as:
  • there is too many query activities when looking for generic participation,
  • there is a lot of semantics creeping into component resource wrapper, in particular about IDependencyComponent
#6

Updated by Henning Blohm almost 9 years ago

  • Status changed from In Progress to Resolved
#7

Updated by Henning Blohm over 8 years ago

  • Status changed from Resolved to Closed
#8

Updated by Henning Blohm over 8 years ago

  • Target version changed from 6 to 2.2

Also available in: Atom PDF