Project

General

Profile

Bug #981

Eclipsoid classpath container does not expose included for in-workspace references

Added by Henning Blohm about 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
z2-base-tools-eclipsoid
Target version:
Start date:
28.02.2013
Due date:
% Done:

100%

Estimated time:
origin:

Description

When referencing a Z project from a Z project in an eclipse workspace, Eclipsoid creates an Eclipse project references between the two projects.

If the dependent project however included libs from the dependency project, say via

java.publicInclude=project2/something

then those are are not exposed via the eclipse project reference.Point is: The Eclipse class path container of the dependency project does not contain all libs from all include components of its module (looking for component type java would be sufficient).

Workaround: Expose them manually by fixing the eclipse project definition of the dependency project.

#1

Updated by Udo Offermann about 8 years ago

The problem is that Eclipsoid only considers the java component as library source.
The solution is to scan all z2 folder-based components.

#2

Updated by Udo Offermann about 8 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset z2-base:tools|commit:e561b0865c590f0f9a3f9613df96455f74d0455a.

#3

Updated by Udo Offermann almost 8 years ago

resolved with Eclipsoid version 2.2.0.201303051605-alpha

Also available in: Atom PDF