Project

General

Profile

Feature #1991

Java 9 Support

Added by Henning Blohm almost 3 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
z2-core
Target version:
Start date:
29.08.2017
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
origin:

Description

See Java9_Support.

Java 9 Support (#1991)

Supporting the Java 9 Language

We integrate ECJ version 4.7.2 from the download link below. Java 9 is fully supported since 4.7.1a (New and Noteworthy 4.7.1a)

We support a new LangLevel.JAVA9 and derive all compiler settings accordingly.

Unfortunately using Java 9 actually requires an updated Jetty version (Jetty9_4_support).

Supporting the Module System

Note: There will be no particular support for Java 9 modules in v2.6

The Java 9 module system provides for module level package exports and cross-module dependencies. As such it does not contradict the class loading delegation model but rather adds that dimension to the module system as Layers.

The module system has migration tools, such as the unnamed module (of the classloader) and automatic modules.

From a Z2 perspective it is almost a binary decision to either:

a) Automatically / semi-automatically modularize all Z2 modules by typically generated module-info data and declarations that support to add legacy modules are automatic modules, or
b) go for completely automatic modules by default.
c) Ignore the Java 9 module layer and stay with unnamed modules and the existing class loader separation

As the module system adds very little value to a Z2 modularized environment and it is currently not clear how forceful other frameworks will adapt module-info data, a first release may opt for c)

References


Subtasks

Feature #1978: Support Java 9 module systemClosed02.09.2017Henning Blohm

Actions
Feature #1977: Support and document use of Java 9Resolved29.08.2017Henning Blohm

Actions
Feature #1992: Support Java 9 Language LevelResolved01.01.2018Henning Blohm

Actions

Related issues

Related to z2-Environment - Improvement #1995: Upgrade Spring addon to v 5.0.6 and Spring security to 5.0.5Resolved06.01.2018

Actions
Related to z2-Environment - Feature #2016: Java 10 supportResolved01.09.2018

Actions
Blocked by z2-Environment - Feature #1993: Upgrade to Jetty 9.4.8Resolved18.04.2018Henning Blohm

Actions
#1

Updated by Henning Blohm almost 3 years ago

#2

Updated by Henning Blohm almost 3 years ago

  • Related to Improvement #1995: Upgrade Spring addon to v 5.0.6 and Spring security to 5.0.5 added
#3

Updated by Henning Blohm over 2 years ago

  • Status changed from In Progress to To Be Documented
#4

Updated by Henning Blohm about 2 years ago

#5

Updated by Henning Blohm about 2 years ago

  • Status changed from To Be Documented to Resolved

Also available in: Atom PDF